INtime SDK Help
nvmecontrol - NVM Express control utility (nvmecontrol.rta)
INtime SDK v7.1 > INtime Utilities > DRTOS Utilities > nvmecontrol - NVM Express control utility (nvmecontrol.rta)

VMECONTROL(8) BSD System Manager's Manual (INtime Distributed RTOS only).

Name

nvmecontrol -- NVM Express control utility

Command line

nvmecontrol devlist

nvmecontrol identify [-v] [-x] <device id>

nvmecontrol perftest <-n num_threads> <-o read|write> [-p] <-s size_in_bytes> <-t time_in_sec> <namespace id>

nvmecontrol reset <controller id>

nvmecontrol logpage <-p page_id> [-x] <device id> <namespace id>

nvmecontrol firmware [-s slot] [-f path_to_firmware] [-a] <device id>

nvmecontrol power [-l] [-p -power_state] [fl w workload_hint]

Description

NVM Express (NVMe) is a storage protocol standard, for SSDs and other high-speed storage devices over PCI Express.

Examples

nvmecontrol devlist
Display a list of NVMe controllers and namespaces along with their device nodes.
nvmecontrol identify nvme0
Display a human-readable summary of the nvme0 IDENTIFY_CONTROLLER data.
nvmecontrol identify -x -v nvme0ns1
Display an hexadecimal dump of the nvme0 IDENTIFY_NAMESPACE data for namespace 1.
nvmecontrol perftest -n 32 -o read -s 512 -t 30 nvme0ns1
Run a performance test on nvme0ns1 using 32 kernel threads for 30 seconds. Each thread will issue a single 512 byte read command. Results are printed to stdout when 30 seconds expires.
nvmecontrol reset nvme0
Perform a controller-level reset of the nvme0 controller.
nvmecontrol logpage -p 1 nvme0
Display a human-readable summary of the nvme0 controller's Error Information Log. Log pages defined by the NVMe specification include Error Information Log (ID=1), SMART/Health Information Log (ID=2), and Firmware Slot Log (ID=3).
nvmecontrol logpage -p 1 -x nvme0
Display a hexadecimal dump of the nvme0 controller's Error Information Log.
nvmecontrol firmware -s 2 -f /tmp/nvme_firmware nvme0
Download the firmware image contained in "/tmp/nvme_firmware" to slot 2 of the nvme0 controller, but do not activate the image.
nvmecontrol firmware -s 4 -a nvme0
Activate the firmware in slot 4 of the nvme0 controller on the next re- set.
nvmecontrol firmware -s 7 -f /tmp/nvme_firmware -a nvme0
Download the firmware image contained in "/tmp/nvme_firmware" to slot 7 of the nvme0 controller and activate it on the next reset.
nvmecontrol power -l nvme0
List all the current power modes. nvmecontrol power -p 3 nvme0 Set the current power mode.
nvmecontrol power nvme0
Get the current power mode.

Authors

nvmecontrol was developed by Intel and originally written by Jim Harris <jimharris@FreeBSD.org>.

This man page was written by Jim Harris <jimharris@FreeBSD.org>.

See Also